1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

RESOLU JsonApi (encore et toujours :') )

Discussion dans 'Problèmes résolus' créé par Lijo62, 9 Mai 2018.

MineStrator, Votre hébergeur de serveur minecraft
Tags:
Statut de la discussion:
N'est pas ouverte pour d'autres réponses.
  1. Lijo62

    Lijo62 Soldat

    18
    0
    1
    Hello tout le monde aujourd'hui j'ai encore un soucis au niveau de JsonApi en effet il semble bien fonctionner sur mon serveur, se lancer sans soucis etc ...

    J'ai bien commandé 3 ports à la suite auprès de mon hébergeur comme prérequis, j'ai bien Vault et ProtocoLibs, tout semble donc aller pour le mieux.

    Cependant la liaison est absolument impossible depuis la site ou octodev.fr/tools/jsonapi/

    Il me semble que les informations que je rentre sont correctes mais rien n'y fais :

    Ip du serveur : irl.serv-mc.eu / irl.serv-mc.eu:25567 / 54.37.177.11 (j'ai essayé les 3)
    Identifiant : mon identifiant de mon user.yml
    Mot de passe : mon mdp de mon user.yml
    Port : 25601




    Logs de mon serveur :
    Code:
    [22:55:53] [Server thread/INFO]: [JSONAPI] Stopping JSON server
    [22:55:53] [Server thread/INFO]: [JSONAPI] Stopping JSON socket server
    [22:55:53] [Server thread/INFO]: [JSONAPI] Stopping JSON WebSocket server
    [22:55:53] [Server thread/INFO]: [JSONAPI] Tearing down API methods
    [22:55:53] [Server thread/INFO]: [JSONAPI] Cancelling performance monitoring
    [22:55:53] [Server thread/INFO]: [JSONAPI] Logging to file: false
    [22:55:53] [Server thread/INFO]: [JSONAPI] Logging to console: true
    [22:55:53] [Server thread/INFO]: [JSONAPI] IP Whitelist = None, all requests are allowed.
    [22:55:53] [Server thread/INFO]: [JSONAPI] Loaded methods.json.
    [22:55:53] [Thread-120/INFO]: [JSONAPI] Waiting 2,000 seconds to load methods so that all the other plugins load...
    [22:55:53] [Thread-120/INFO]: [JSONAPI] Any requests in this time will not work...
    [22:55:54] [Thread-120/INFO]: [JSONAPI] Dynmap cannot be loaded because it depends on a plugin that is not installed: 'dynmap'
    [22:55:54] [Thread-120/INFO]: [JSONAPI] Remote Toolkit cannot be loaded because it depends on a plugin that is not installed: 'RemoteToolkitPlugin'
    [22:55:54] [Thread-120/INFO]: [JSONAPI] Dynmap cannot be loaded because it depends on a plugin that is not installed: 'dynmap'
    [22:55:54] [Thread-120/INFO]: [JSONAPI] Remote Toolkit methods cannot be loaded because it depends on a plugin that is not installed: 'RemoteToolkitPlugin'
    [22:55:54] [Thread-120/INFO]: [JSONAPI] 384 methods loaded in 7 namespaces.
    [22:55:54] [Thread-120/INFO]: [JSONAPI] ------[Connection information]-------
    [22:55:54] [Thread-120/INFO]: [JSONAPI] JSON Server listening on 25601
    [22:55:54] [Thread-120/INFO]: [JSONAPI] JSON Stream Server listening on 25602
    [22:55:54] [Thread-120/INFO]: [JSONAPI] JSON WebSocket Stream Server listening on 25603
    [22:55:54] [Thread-120/INFO]: [JSONAPI] Active and listening for requests.
    [22:55:55] [Server thread/INFO]: [JSONAPI] Attempting to use port 25601
    [22:55:55] [Thread-120/INFO]: [JSONAPI] External IP: 54.37.177.11
    [22:55:55] [Thread-120/INFO]: [JSONAPI] Port 25601 is properly forwarded and is externally accessible.
    [22:55:55] [Thread-120/INFO]: [JSONAPI] Port 25602 is properly forwarded and is externally accessible.
    [22:55:56] [Thread-120/INFO]: [JSONAPI] Port 25603 is properly forwarded and is externally accessible.

    J'ai fais de multiples tentatives, regardé de nombreux tutos, essayé de mettre le fameux "NewApi" sur false, mais rien ne fonctionne ...

    Avez vous des idées ? Merci d'avance !
     
  2. Florentlife

    Florentlife Administrateur Forum CMW Staff Administrateur Forum Développeur officiel de CraftMyWebsite

    2 595
    376
    83
    Yo,

    Hébergeur web ?
     
  3. Lijo62

    Lijo62 Soldat

    18
    0
    1
    Salut, tout d'abords merci de ta réponse, notre hébergeur Web est LiveHost donc normalement tout les ports sont ouverts, cependant le soucis est que même les sites tel que celui d'octodev ne repère pas notre JSONAPI et pourtant tout semble fonctionner, d'où le problème :/
     
  4. Florentlife

    Florentlife Administrateur Forum CMW Staff Administrateur Forum Développeur officiel de CraftMyWebsite

    2 595
    376
    83
    Alors Hébergeur mc ? xD
     
  5. Lijo62

    Lijo62 Soldat

    18
    0
    1
    Notre hébergeur Mc est HostMyServers, les ports ont normalement été aloué selon l'hébergeur ^^
     
  6. Emilien52

    Emilien52 Administrateur Forum CMW Staff Administrateur Forum Développeur officiel de CraftMyWebsite Modérateur Support

    364
    25
    28
    Demande à leur support qu'elle ports devais vous utilisez pour jsonapi (à votre hébergeur mc)
     
  7. Lijo62

    Lijo62 Soldat

    18
    0
    1
    C'est eux qui nous ont dit d'utiliser le port 25601/25602/25603 :/
     
  8. Emilien52

    Emilien52 Administrateur Forum CMW Staff Administrateur Forum Développeur officiel de CraftMyWebsite Modérateur Support

    364
    25
    28
    Dite leur qu'ils ne marchent pas
     
  9. Florentlife

    Florentlife Administrateur Forum CMW Staff Administrateur Forum Développeur officiel de CraftMyWebsite

    2 595
    376
    83
    Si normalement ça marche possible d'avoir tes identifiants jsonapi en pv stp
     
  10. Lijo62

    Lijo62 Soldat

    18
    0
    1
    Salut oui ça ne fonctionne toujours pas alors qu'on vient de demander à changer de port donc je dois vraiment être nul xD
     
    • J'accepte J'accepte x 1
  11. Florentlife

    Florentlife Administrateur Forum CMW Staff Administrateur Forum Développeur officiel de CraftMyWebsite

    2 595
    376
    83
Statut de la discussion:
N'est pas ouverte pour d'autres réponses.

Partager cette page

Chargement...