1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies. En savoir plus.

Supreme | Bêta

Discussion dans 'Vos Thèmes CraftMyWebsite' créé par Amjido, 23 Juin 2017.

MineStrator, Votre hébergeur de serveur minecraft
  1. Florentlife

    Florentlife Administrateur Forum CMW Staff Administrateur Forum Développeur officiel de CraftMyWebsite

    2 595
    376
    83
    Modifie le <button>(ou le <a> je sais jamais) qui contient ton adresse ip, en <a ip="ton adresse ip" class="copy_button"> (tu peux rajouter les class qui était dans ton <button> ou <a> précédent)

    Puis en bas de la page index de ton thème, tu rajoute
    HTML:
    <script>
    $('.copy_button').on( 'click', function(e){
                    copyToClipboard( $(this).attr('ip') );
                    toastr.info('IP copié dans le presse-papier ! ')
                });
    
                function copyToClipboard(element) {
                    var $temp = $("<input>");
                    $("body").append($temp);
                    $temp.val(element).select();
                    document.execCommand("copy");
                    $temp.remove();
                }
    </script>
    alors, je sais plus si supreme intègre le script toastr, si après avoir cliquer sur le bouton et que ça te l'a copié il ny'a pas de petite fenêtre disant que c'est copié, dit le moi
     
    • J'aime J'aime x 1
  2. DogeMVP

    DogeMVP Soldat

    36
    5
    8
    Tu peux aussi faire
    Code:
    copyToClipboard($(this).text());
    (vu que le texte entre les balise <a> = l'ip)
    ça évite de mettre un attribut ip dans le <a>

    Et oublie pas de mettre ton script dans:
    Code:
    $(document).ready(function() {
    
    });
     
    • J'aime J'aime x 1
    • J'accepte J'accepte x 1
    Dernière édition: 26 Novembre 2017
  3. vortos

    vortos Soldat

    23
    0
    1
    Ok merci beaucoup, je testerai le week end prochain.
     
  4. IliTy

    IliTy Soldat

    4
    0
    1
    d'accord mais je glisse ou le code ?
     
  5. vortos

    vortos Soldat

    23
    0
    1
    Merci à Florentlife et à DogeMVP pour l'aide. J'ai testé le code de Florentlife et ça fonctionne. Effectivement il n'y a pas de petite fenêtre disant que c'est copié mais je n'en n'ai pas besoin. J'ai juste dû faire 2-3 modifs car le code n'était pas adapté au thème.
    J'ai modifié ce script que j'ai placé entre les balises "<body>","</body>" (tout en bas).
    <script>
    $('.copy_button').on( 'click', function(e){
    copyToClipboard( $(this).attr('ip') );
    toastr.info('IP copié dans le presse-papier ! ')
    });

    function copyToClipboard(element) {
    var $temp = $("<input>");
    $("body").append($temp);
    $temp.val(element).select();
    document.execCommand("copy");
    $temp.remove();
    }
    </script>

    en ce script car il faillait que je modifie la class en id pour pas que ça rentre en conflit avec le code de la page "acceuil.php"
    <script>
    $('#copy_button').on( 'click', function(e){
    copyToClipboard( $(this).attr('ip') );
    toastr.info('IP copié dans le presse-papier ! ')
    });

    function copyToClipboard(element) {
    var $temp = $("<input>");
    $("body").append($temp);
    $temp.val(element).select();
    document.execCommand("copy");
    $temp.remove();
    }
    </script>

    Au niveau de "<div class="container">" et "</div>" de la page "acceuil.php" j'ai modifié le code (qui affiche l'ip) en :
    <a ip="le texte à copié" id="copy_button" class="btn btn-normal"><?php echo($ip); ?></a>
    C'est là qu'on comprend pourquoi j'ai modifié le script en id et que je ne l'ai pas laissé en class.
    Si je l'avais laissé en class étant donné qu'il y avait déjâs une class attribué ça allé rentré en conflit et un des deux aurait prit le dessus. Au final je n'ai fait qu'ajouté :
    ip="le texte à copié" id="copy_button"
     
  6. Florentlife

    Florentlife Administrateur Forum CMW Staff Administrateur Forum Développeur officiel de CraftMyWebsite

    2 595
    376
    83
    Nop, tu aurais pu mettre class="btn btn-normal copy_button", comme y'a pas de css avec copy_button, y'a pas de soucis ;)
     
  7. vortos

    vortos Soldat

    23
    0
    1
    ok je ne savais pas merci pour l'info :)
     
  8. WareZ

    WareZ Soldat

    16
    3
    3
    Pour quand la 0.3 ? :)
     
    • J'aime J'aime x 1
  9. flogholly

    flogholly Soldat

    39
    9
    8
    @Amjido Cela fait un moment que je cherches mais je n'arrive pas a trouver :/ Je préfère m’adresser directement au créateur ^^ Serais tu ou je peux modifier pour changer les couleurs du thème ? (Changer le rouge en bleu)
     
  10. Amjido

    Amjido Général de division ✬✬

    863
    246
    63

    Merci de vous Connecter/S'inscrire pour voir les liens.

    Voilà l'exemple, dans index.php du thème t'as la ligne suivante :
    <link href="Merci de vous Connecter/S'inscrire pour voir les liens." id="main-color" rel="stylesheet" type="text/css"> red.css que tu changes avec les fichiers de couleurs disponibles dans le dossier color situé dans assets/color du thème

    Assez longtemps compte tenu de certains soucis de droits, j'pense faire d'autre thèmes plutôt dans le même style
     
  11. flogholly

    flogholly Soldat

    39
    9
    8
    Merci beaucoup de ton aide :)
     
    • J'aime J'aime x 1
  12. G59K

    G59K Soldat

    2
    1
    3
    Bonsoir,
    Je début dans les CMS, du coup je ne sais pas comment je pourrais installer ce thème ... Si il y aurais moyen de m'aide.
    Merci
     
  13. Amjido

    Amjido Général de division ✬✬

    863
    246
    63
    Passes privé je vais t'expliquer ^^ ou ajoute moi discord amjido#3474
     
  14. G59K

    G59K Soldat

    2
    1
    3
    Je t'ai demande en ami
     
    • J'aime J'aime x 1
  15. antoinebruf

    antoinebruf Soldat

    6
    0
    1
    Bonjour, je viens d'installer le thème et tout va parfaitement sauf le forum.
    Je n'arrive pas à ajouter des forums dans les catégories ou encore Lire /supprimer / voir un post écrit dans le forum :/

    Je suis le seul avec ce problème ? :(
     
  16. Florentlife

    Florentlife Administrateur Forum CMW Staff Administrateur Forum Développeur officiel de CraftMyWebsite

    2 595
    376
    83
    Le thème est pas compatible 1.6
     
  17. 0xymoree

    0xymoree Soldat

    3
    0
    1
    Bonjour,

    j'ai un petit soucis avec le forum, il met impossible d'aller sur un topic. j'ai reussi a cree un forum--une catégorie et un topic mais ce dernier me redirige vers une page blanche :/ l'url est bien la bonne (?&page=post&id=1) le topics est bien présent dans la base sql avec le bon id.

    une idée?

    merci :)
     
  18. Florentlife

    Florentlife Administrateur Forum CMW Staff Administrateur Forum Développeur officiel de CraftMyWebsite

    2 595
    376
    83
    Yo,

    Possible d'avoir le lien de ton site stp ?
     
  19. 0xymoree

    0xymoree Soldat

    3
    0
    1

    Bonjour,

    le site est pas encore en ligne et j'ai réussi a réglé le problème du forum en rajoutant "require('modele/forum/forum.class.php');
    $_Forum_ = new Forum($bddConnection);" dans preload.php.

    j'ai un autre problème, les grades, j'ai crée un grade "web-master" dans le pannel avec toutes les autorisation mais je n'est pas accès au site en maintenance avec ce grade juste au panel, je suis obliger de me mettre créateur pour accéder au site.
     
  20. Florentlife

    Florentlife Administrateur Forum CMW Staff Administrateur Forum Développeur officiel de CraftMyWebsite

    2 595
    376
    83
    Possible de venir sur le discord ?
     

Partager cette page

Chargement...